登录 注册

登录

问题 白站长,请问用joomla做中文网站,能兼用IE6、IE7、IE8吗

更多
2014年03月13日 15:00 #1 作者: 吴涛
如题,能详细点吗,谢谢 :P

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月13日 19:20 #2 作者: Joomla之门
IE 浏览器(全名:Internet Explorer)是微软公司的产品,这个带有垄断性质的浏览器一直都是被网页设计人员唾弃的对象。因为微软曾经试图利用 IE 用户群最大为筹码,要挟整个互联网都改变标准。IE 6、7、8 甚至 9 都有与 W3C 标准不相符的地方。

Joomla 是开源软件,它不受微软公司控制,所以,Joomla 的开发人员,尤其是模板设计人员,基本上不考虑对 IE ,尤其是低版本 IE 浏览器的支持。—— 为什么要支持一个垃圾浏览器?仅仅是为了迁就仍然固执地使用垃圾浏览器的垃圾访客,我们就要放弃 web 标准?放弃 CSS3 及 HTML5 ?放弃本来可以非常简洁、优雅、高效的网页设计方案?

我劝你趁早打消这个念头。哪怕在中国 IE 浏览器占据的用户群仍然最大,也无法改变它是垃圾这个事实 —— 尤其是低版本 IE 浏览器!

Joomla 站长应该怎么做?你应该在你的网站上安装一个插件(例如: Browser Update Warning 插件 ),提醒访客升级浏览器 —— 要么升级到 IE10/11 ,要么换用 FireFox 或 Chrome 或 Safari 、Opera 等符合 web 标准、尊重 web 标准的“现代化”浏览器。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月26日 23:31 #3 作者: Firewings
不好来得,IE6还是放弃了吧。不然只有用国内开发的模板,但是你会发现国内的JOOMLA好看的少之又少。

登录 或者   注册一个会员帐号 来参与讨论