登录 注册

登录

已解决 网站上下载的joomla3.2.3多国语言核心数据库不匹配

更多
2014年03月22日 23:56 #1 作者: 陈先生
反复试了几次重装,装完都会提示:
警告:資料庫不是最新的!
找到 1 資料庫問題
其他資訊

資料庫結構版本 (3.2.3-2014-02-20) 不符合 CMS 版本 (3.2.3)

警示:数据库未更新!
发现1条数据库问题
其它信息

数据库模式版本(3.2.3-2014-02-20)与CMS版本(3.2.3)不吻合。

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月23日 02:03 #2 作者: Joomla之门
你安装时数据库选择的是 MySQLi 吗?还是选择了 postgresql 或者 sqlazure?

本站制作的 Joomla 3.2.3 中文版核心 我安装过好几次了,没有碰见过你说的这个问题。

不过为了谨慎起见,我刚刚用官方英文原版又重新添加中文语言包做了一次,更新了下载栏目的文件。请重新下载安装试试看。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月24日 01:39 #3 作者: Johnny
下列用户已致谢:: Joomla之门

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月24日 14:56 #4 作者: 陈先生
是选择地MySQLi,本站的joomla3.2.3中文版和官网的英文版,都装了,全都出这个问题,用的阿里云服务器,Ubuntu系统,Apache环境

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月24日 19:50 #5 作者: Joomla之门
很奇怪的一点是,我安装过很多次这个核心,从来没碰到过这个错误。

你所看到的:

警告:資料庫不是最新的


是在什么时候、什么页面上、什么操作之后看到的?能否详细描述出现的过程,最好有截图。我至今还不明白这个问题到底是怎么发生的?

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月24日 20:18 #6 作者: Johnny
附件:

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月24日 20:35 #7 作者: 陈先生

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月24日 20:36 - 2014年03月24日 20:36 #8 作者: 陈先生

很奇怪的一点是,我安装过很多次这个核心,从来没碰到过这个错误。

你所看到的:

警告:資料庫不是最新的


是在什么时候、什么页面上、什么操作之后看到的?能否详细描述出现的过程,最好有截图。我至今还不明白这个问题到底是怎么发生的?


警示:数据库未更新!
发现1条数据库问题
其它信息

数据库模式版本(3.2.3-2014-02-20)与CMS版本(3.2.3)不吻合。

就是六楼截图的情况,和我遇到的是同样的问题,安装完joomla3.2.3核心不用安装语言包就已经报这个错了
最后修改: 2014年03月24日 20:36 由 陈先生.

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月24日 21:55 #9 作者: Joomla之门
看了截图明白是什么问题了。

Johnny 在上面不是已经给出了解决办法么:

Fixing version comparison for database schema #3249

github.com/joomla/joomla-cms/pull/3249/files


这个实际上不是数据库错误,只是一个“误判”的错误。官方已经给出了解释:

Database schema version (3.2.3-2014-02-20) does not match CMS version (3.2.3)

你可以忽略这个错误,下一个版本自动就会纠正。也可以使用上面提到的补丁来处理。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!
下列用户已致谢:: 陈先生

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年03月24日 22:48 - 2014年03月25日 05:21 #10 作者: 陈先生
最后修改: 2014年03月25日 05:21 由 Joomla之门. 原因: 删除不必要的引用

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年04月02日 08:45 #11 作者: lixiao
3.2用升级包升3.2.3的也出这个问题。

登录 或者   注册一个会员帐号 来参与讨论

更多
2014年04月02日 16:24 #12 作者: Joomla之门
下一个版本 Joomla 3.3 将于 2014年4月22日发布,估计在新版本中应该会解决这个问题。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论