登录 注册

登录

问题 joomla从3.3.3 升级3.4.5报错怎么办?

更多
2015年11月05日 09:58 - 2015年11月05日 10:00 #1 作者: dengb
我之前在阿里弄了个试用的,从3.3.3升级到3.4.5就没事,这次换了一个也是从3.3.3升级到3.4.5,进度条一开始就报错,文件损坏什么的?
然后就一直报错,也没有备份,我可以直接用最新版本的joomla直接覆盖么??
最后修改: 2015年11月05日 10:00 由 dengb.

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年11月05日 16:44 #2 作者: Joomla之门
升级操作的最重要一个准备工作就是:先把旧站备份一下。

你既然没有备份,现在只能“死马当作活马医”了。建议把网站迁移到本地测试服务器上再进行操作:

1、首先再次尝试手工升级(通过后台 “扩展 -> 扩展管理” 来安装升级包);
2、如果已经无法访问后台,尝试用最新版本的 Joomla 核心包(去掉 installation 目录)覆盖;

如果以上方法都行不通,恐怕这个网站就废了。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年11月05日 16:50 #3 作者: dengb
反正也是刚开始随便弄的,我就把升级包直接解压覆盖了,结果登陆后台显示是最新版本了,,其他功能也没问题,之前的网站也能打开,这样有隐患么?

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年11月05日 16:58 #4 作者: Joomla之门
如果新旧两个版本之间没有数据库的变化,仅仅是文件系统的变化,那么用“文件包覆盖”当然可以实现完全的升级。但是,如果存在数据库的变化,必须经过“安装升级”这个步骤,才能自动完成数据库的升级。

我一直都是安装升级的,所以不清楚 Joomla 3.3.3 至 3.4.5 之间到底有没有数据库的变化。如果有的话,你的升级结果应该是不完整的。继续使用这样的升级结果当然存在隐患。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2015年11月05日 17:07 #5 作者: dengb

登录 或者   注册一个会员帐号 来参与讨论