登录 注册

登录

问题 后台开启“搜索引擎友好链接”后,页面全乱了,没了样式表。

更多
2008年08月20日 10:59 #1 作者: 小鱼
Joomla1.50安装在Linux虚拟主机上,安装的时候提示了 如图片所示。

我没关 继续下一步进行安装 ,安装完毕后,在后台设置 搜索引擎友好连接后 前台页面就全乱了,请问是跟 安装的时候出现的那个错误有关吗?

Joomla 很好,很强大。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月20日 17:31 #2 作者: Joomla之门
你所说的“全乱了”是什么意思?

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月21日 08:53 #3 作者: 小鱼
www.bjlvyuan.com/index.php/typography-mainmenu-26.html
老白你看下这个链接,就是CSS样式表都没有加载进来。

Joomla 很好,很强大。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月21日 08:59 #4 作者: Joomla之门
请切换到默认模板!

貌似你安装的 JA 模板不支持 SEF 功能。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月21日 09:27 #5 作者: 小鱼
Joomla里面就只有这个模板 我下载的是一个含有模板集成代码的 版本 没有joomla的默认模板 只有这一个模板rochea
哦 还有为什么我本地安装这个就能开启那个sef的功能,而且没有任何问题呢?

Joomla 很好,很强大。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月21日 09:28 #6 作者: 小鱼
是跟我的linux虚拟主机有关系吗?就像我第一次发的那个图上一样 那个 output buffering 没有开启

Joomla 很好,很强大。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月21日 09:59 #7 作者: Joomla之门
我倒!你提问的时候怎么不说清楚你用的核心是一个 QuickStart?

这个问题跟你的服务器 output buffering 没有任何关系!

这个 quickstart 安装包有问题。你如果还有关于这个安装包的问题,可以咨询一下 JA 公司,天知道他们怎么打包的。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 16:57 #8 作者: 小鱼
老白,多谢你的回答,不过又我重新试了一下。
我在Linux上安装的1.56的版本,然后再通过后台上传了,Rochea 所需的 module 和 template 然后,设置完 开启搜索引擎友好话后,还是出现了这个问题。
这次安装1.56的中文版joomla后,在安装检测系统的时候出现了 两处红色提示,1.Display_error 2.outputting_buffer 两处都显示了红色。
www.bjlvyuan.com 劳您再看下。
请问是不是因为这个模板不适应Linux呢,我在windows下什么问题都没有。

Joomla 很好,很强大。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 17:02 #9 作者: 小鱼
是不是需要在全局设置里面 开启 "使用Apache的重写模式:mod_rewrite "这个.

Joomla 很好,很强大。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 19:28 #10 作者: suiyue
我也遇到此问题.windows的空间就没事,Linux就有问题

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 20:44 #11 作者: 小鱼
LS解决了吗?
难不成这个得需要修改代码不成?

Joomla 很好,很强大。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月24日 15:00 #12 作者: gothicwolf
我开户了搜索引擎友好链接后,页面的链接全打不开了。。。。。。。。。。。急呀

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月24日 15:36 #13 作者: chen_edward
我也有同样问题,打开搜索引擎友好链接后,页面链接都变成了别名,统统打不开

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月25日 12:34 #14 作者: mymoola
是不是像 suiyue 讲的那样windows的空间就没事,Linux就有问题? 我用的Linux空间,开的话连接没事,就是开添加后缀名 那里开启的话,连接就都出错了

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月29日 06:51 #15 作者: 小鱼
各位我的问题已经解决了,是我这边自己的问题,抱歉实在是没时间看文档。
Linux下,若要开启搜索引擎友好话,首先要把根目录下htaccess.txt 修改为为 .htaccess 【因为Linux下不识后缀名】 然后再后台 全局设置那块 mod_rewrite 还要开启 。就可以了。
希望对上面几位有所帮助。

Joomla 很好,很强大。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月29日 07:33 #16 作者: 歌笑填鸭
楼主的皮肤很好看!!!

^_^
在linux系统下面安装所有的网站程序,都要看看.htaccess 是否存在,以及存在是为了什么!!!

有关这方面的问题你可以看看http://www.baidu.com/s?wd=.htaccess+

我的个人blog,欢迎大家交换链接:
歌笑填鸭‘S BLOG

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年10月29日 15:59 #17 作者: youngboy2003
最后这个问题怎么解决的?我也碰到了,很郁闷

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年10月29日 16:56 #18 作者: tiger
用的哪个模版,能否共享一下?我正在找这样的!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年10月29日 17:01 #19 作者: youngboy2003
用的默认的rhuk_milkyway
win主机就不会出现这样的问题,linux的开了搜索引擎友好链接就没样式表了,图片也不显示。
如这样:http://www.titon.net.in/index.php/about-joomla

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年11月03日 20:07 #20 作者: zhuce2008
呵呵...
楼主说的没错! 确实是需要在后台启用那两个友好链接和Apache的重写设置, 并在启用前先将安装目录下文件 htaccess.txt 改名为 ".htaccess" 即可, 完成设置后就不会出现前台页面错乱的现象了.

下面我已经附加此设置图,供大家参考. 希望有类似问题的老兄能得到启示.

登录 或者   注册一个会员帐号 来参与讨论