登录 注册

登录

问题 请教高手——迁移问题报HTTP500错误

更多
2010年12月23日 03:03 #1 作者: jackma
小弟公司有两个用joomla开发的网站,原来放在外面租用的空间上,最近公司刚买了服务器,老大要求把网站迁移到咱们自己的服务器上.迁移的时候出现了问题,其中一个网站无论如何都不能显示内容,总是报HTTP500的错误,后台管理首页能够显示,但是输入密码回车也会出现HTTP500的错误,提示如下:

This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

小弟看不太懂这个提示,请问是权限问题吗?该如何设置?
而另外一个网站却能正常运行,后台管理界面维护站点也没有任何问题,这两个网站的设置大概看了一下,大部分是一样的
服务器的OS是windows2008R2 64bit, apache2.2.17+mysql5.5.8+php5.3.4+phpmyadmin
各位大哥帮帮忙啊~
下列用户已致谢:: 279989280iou, my4009

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年12月23日 11:42 #2 作者: yecao
不清楚怎么解决,不过我遇到的500错误基本和htaccess.txt文件有关,找找原因吧

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年12月23日 14:43 #3 作者: jackma
大哥能说得详细点吗?应该怎么设置?

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年12月23日 14:51 #4 作者: bithost
查找apache访问日志,很多方面都会导致500错误的。

想让你的Joomla网站更快吗?使用Bithost 合租空间 www.bithost.cn
完全兼容Joomla,电信网通美国三线空间。
另有美国合租空间(独立IP)
Email webmaster+bithost.cn
QQ 48269819
可以试用 可以月付

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年12月25日 11:31 #5 作者: jackma
127.0.0.1 - - [25/Dec/2010:19:10:11 +0800] "GET /**** HTTP/1.1" 301 240
127.0.0.1 - - [25/Dec/2010:19:10:11 +0800] "GET /****/ HTTP/1.1" 500 -

****是小弟公司网站地址

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年12月25日 15:39 #6 作者: bithost
你日志内容太少了。

想让你的Joomla网站更快吗?使用Bithost 合租空间 www.bithost.cn
完全兼容Joomla,电信网通美国三线空间。
另有美国合租空间(独立IP)
Email webmaster+bithost.cn
QQ 48269819
可以试用 可以月付

登录 或者   注册一个会员帐号 来参与讨论

更多
2010年12月27日 14:38 #7 作者: jackma
我也觉得少了,可是真的就只有那么多,要是多点就好办了:huh:

登录 或者   注册一个会员帐号 来参与讨论

更多
2011年01月10日 16:22 - 2011年01月10日 16:25 #8 作者: jackma
网站从租用的空间迁移到本地服务器,空间上的环境是windows2003+II6+MYSQL+PHP,服务器环境windows2008(64bit)+IIS7+PHP+MYSQL
本地服务器环境配置好了,phpinfo显示了,phpmyadmin也能正常登录mysql,但是网站迁移过来后总是提示以下错误,于是新建了一个全新的joomla网站,在最后一步删除installation文件夹后,还是提示一样的错误,有哪位大哥解决过这个问题的吗,小弟找遍了很多网站资料都没能解决,这个站有高手吗?

Strict Standards: is_a(): Deprecated. Please use the instanceof operator in C:\inetpub\wwwroot\Joomla\libraries\joomla\error\error.php on line 80

Strict Standards: is_a(): Deprecated. Please use the instanceof operator in C:\inetpub\wwwroot\Joomla\libraries\joomla\error\error.php on line 80

Strict Standards: is_a(): Deprecated. Please use the instanceof operator in C:\inetpub\wwwroot\Joomla\libraries\joomla\error\error.php on line 80

Strict Standards: Non-static method JSite::getMenu() should not be called statically, assuming $this from incompatible context in C:\inetpub\wwwroot\Joomla\includes\router.php on line 383

Strict Standards: Non-static method JApplication::getMenu() should not be called statically, assuming $this from incompatible context in C:\inetpub\wwwroot\Joomla\includes\application.php on line 345

Strict Standards: Non-static method JLoader::import() should not be called statically in C:\inetpub\wwwroot\Joomla\libraries\loader.php on line 186

Strict Standards: Non-static method JMenu::getInstance() should not be called statically, assuming $this from incompatible context in C:\inetpub\wwwroot\Joomla\libraries\joomla\application\application.php on line 705

Strict Standards: Non-static method JError::isError() should not be called statically, assuming $this from incompatible context in C:\inetpub\wwwroot\Joomla\libraries\joomla\application\application.php on line 706

Strict Standards: is_a(): Deprecated. Please use the instanceof operator in C:\inetpub\wwwroot\Joomla\libraries\joomla\error\error.php on line 80

Strict Standards: is_a(): Deprecated. Please use the instanceof operator in C:\inetpub\wwwroot\Joomla\libraries\joomla\error\error.php on line 80

Strict Standards: is_a(): Deprecated. Please use the instanceof operator in C:\inetpub\wwwroot\Joomla\libraries\joomla\error\error.php on line 80

Strict Standards: Non-static method JURI::base() should not be called statically, assuming $this from incompatible context in C:\inetpub\wwwroot\Joomla\includes\router.php on line 109

Strict Standards: Non-static method JRegistryFormat::getInstance() should not be called statically, assuming $this from incompatible context in C:\inetpub\wwwroot

....以下省略N字
最后修改: 2011年01月10日 16:25 由 jackma.

登录 或者   注册一个会员帐号 来参与讨论

更多
2011年02月28日 16:33 #9 作者: mei1si
同问 好像说修改php.ini的错误提示。。实验不行。

登录 或者   注册一个会员帐号 来参与讨论

更多
2011年03月01日 01:10 - 2011年03月01日 04:20 #10 作者: musicpig
把php.ini的错误提示关掉,网上自己搜搜,有很多的
最后修改: 2011年03月01日 04:20 由 Joomla之门.

登录 或者   注册一个会员帐号 来参与讨论

更多
2011年03月01日 01:32 #11 作者: bithost
话说,你为什么要这么高版本的php和mysql。
mysql5.5.8 php5.3.4

想让你的Joomla网站更快吗?使用Bithost 合租空间 www.bithost.cn
完全兼容Joomla,电信网通美国三线空间。
另有美国合租空间(独立IP)
Email webmaster+bithost.cn
QQ 48269819
可以试用 可以月付

登录 或者   注册一个会员帐号 来参与讨论

更多
2011年03月02日 03:16 - 2011年03月02日 03:34 #12 作者: mei1si
最后修改: 2011年03月02日 03:34 由 Joomla之门.

登录 或者   注册一个会员帐号 来参与讨论

更多
2011年03月04日 02:20 #13 作者: jackma
早解决了,呵呵,php.ini里面的output_buffering = off 改为on,然后把php.ini放到c:\windows目录下就好了

登录 或者   注册一个会员帐号 来参与讨论