登录 注册

登录

问题 急寻:文章投票插件

更多
2008年08月19日 16:50 #1 作者: xiaoxiao2008
白老师:有没一个这样的插件,每篇文章下都包含评分(1星期级最低,5星级最高)的功能及评价什么的,然后再以电邮传送给好友。。。其实也就是文章投票的插件,令我特奇怪的是:joomla里自带有这个功能,我都还找到相应的代码了,但不知为什么,前台就是没显示出来,(前提是,我都发布了);这是怎么回事,白老师帮帮忙啊。。。。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月20日 09:23 #2 作者: Joomla之门
Joomla! 1.5 已经自带 rating 功能,默认在“插件管理”中已经启用了 content - rating 这个插件。

前台文章中没有显示的原因是:在后台“文章管理”界面的“统一参数”中,”文章评级/投票“这一项默认是“隐藏”。你必须选择“显示”才能在前台看到用于投票/评分的星星。如果你设置了这里的参数,还没有看到前台的评分功能,那么就需要逐一打开那些没有显示的文章,在文章撰写窗口右侧的“高级参数”中,将“文章评级”一项选择为“显示”。

很不幸!默认的评分标志是5个圆圈,而不是星星。不过已经有人开发了带星星的评分插件,我改天汉化了发布上来。

至于“推荐给朋友”功能,Joomla! 也是自带的。前台文章标题右侧的“e-mail” 图标就是干这个的。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月20日 10:54 #3 作者: xiaoxiao2008
嗯,显示出来了,还是白老师对joomla熟,具体的哪个参数都那么清楚,看来我这个新手得加油了。 谢谢白老师!!! ;)
不过有点不明白,当我注册成功登录进去后,对一篇文章进行评价,没起效果,总是默认状态为好,评价人数也总是0,这是怎么回事???还有,发送给好友的emali也成功,提示:

        * 无法呈现邮件功能(没有设置好发送Email的相关项目)
        * EMAIL_NOT_SENT
我记得有按你说的那样去做(注册成功后,没有收到激活邮件时),但也不成功,所以我只能在后台把新创建的用户发布才可登录,这个邮件的设置,到底要怎么样设置才好???


另外,白老师,你能否把英文版(有星星的)文章投票插件先公布出来,我现在急需呢,呵呵,先谢了。。。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月21日 10:43 - 2008年08月21日 11:17 #4 作者: xiaoxiao2008
白老师,怎么不回复我呢,我一直在等待你的回复呢。。。
最后修改: 2008年08月21日 11:17 由 chinalights.

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月21日 11:28 #5 作者: Joomla之门
邮件设置问题请在相关话题中跟帖讨论。

今天汉化了一个 Core Design Ajax Vote 文章评分插件 ,但是我测试时失败了。你可以自己试试看。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月21日 22:49 #6 作者: next001
请问老大怎样打来jQuery JS,因为我装了Core Design Ajax Vote 文章评分插件。但不会打开jQuery JS

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 07:53 #7 作者: Joomla之门
你安装 Core Design Scriptegrator plugin 脚本库系统插件 了吗?

请仔细阅读下载说明!

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 11:36 #8 作者: xiaoxiao2008
白老师,按照你的指示,我把需要的两个插件都下载下来了,遵照描述,如:如果要使用 Core Design Ajax Vote 文章评分插件,就必须安装本插件并启用 jQuery JS。这个启用jQuery JS是什么意思,不明白???
Core Design Scriptegrator plugin ,Core Design Ajax Vote 两个都已安装成功,且在后台启用了他们,但前台并没有效果啊,这是什么原因呢,老师快快指教啊... ???

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 15:16 #9 作者: xiaoxiao2008
白老师,你可真是个大忙人呢,呵呵,你好像忘了回复我的问题了,我可一直到等你的回复呢!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 15:29 #10 作者: Joomla之门
你的问题等于是在浪费别人的时间 —— jQuery JS 就在 参数里面明明白白列着,你启用就行了,这个还要解释一下吗?你有没有看两个插件的参数?

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 16:35 #11 作者: xiaoxiao2008
:(  55555...,白老师这样来说学生,学生是相信你才问你的,且本人是新手,我只会把插件拿来安装,使用,至于他具体怎么实现的我一时半会也弄不明白呀,所以才问你。。。
不过还是要谢谢你给予指示。。。

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 16:45 #12 作者: Joomla之门
唉,我乐意帮助别人,但是也不能不看参数就来问啊。

在提问之前,先把你能做的工作都做好。

还有,不要“老师”“老师”的,我很不安,我也不是什么高手,只是比较喜欢 Joomla! 而已。

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月22日 20:00 #13 作者: next001
谢谢 老大啊

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月26日 10:48 #14 作者: xiaoxiao2008
OK!以后我会注意点,谢谢!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月27日 08:53 #15 作者: mymoola
我上传了Core Design Scriptegrator plugin 脚本库系统插件  ,2个都开了 但是前台没有显示, 是因为插件配置问题吗? 请问你们是怎么配置的?

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月27日 13:25 #16 作者: jackyking
这个评分的功能,需要在后台文章管理的全局设定中打开的

不推荐CD ajax vote,太难用了...推荐Extravote 或者 VOTItaly ,单纯ajax vote的话,没必要用greatjoomla的,还是商业的

文件附件:

本站维护下列组件汉化
  • Community Builder 1.2RC4 Qcontacts
  • uddeIM 1.6  Custom Properties Alphauserpoints
  • JomComment JComments JFusion

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月27日 15:59 #17 作者: Joomla之门
我看了 Core Design ajax vote 插件的 XML 文件,不是商业软件,用的 License 是 Attribution-NonCommercial 3.0 Unported。不过我安装之后确实没法用。

感谢 jackyking 的推荐,我刚刚汉化了 VOTItaly 文章评分插件

付费下载 Joomla 3 扩展汉化版: 我要付费支持 Joomla 之门!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月28日 03:53 #18 作者: 歌笑填鸭

我看了 Core Design ajax vote 插件的 XML 文件,不是商业软件,用的 License 是 Attribution-NonCommercial 3.0 Unported。不过我安装之后确实没法用。

感谢 jackyking 的推荐,我刚刚汉化了 VOTItaly 文章评分插件


CD Ajax Vote 的插件确实是免费的——暂时
还有VOTItaly之前已经有人汉化过了,我用的就是他的汉化版!
地址是:http://www.webtmp.cn/plugin-guidebook/site-enhancement-plugins/53-extravote-votitaly-joomla-ajax-rating.html

我的个人blog,欢迎大家交换链接:
歌笑填鸭‘S BLOG

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月28日 10:51 #19 作者: mymoola
VOTItaly 哈哈 昨晚刚装上 ,但是前台也不显示, 不知是不是我哪里设置的不对了, 白大哥出汉化了 装上再试试  , 感谢 感谢!!!

登录 或者   注册一个会员帐号 来参与讨论

更多
2008年08月28日 11:13 #20 作者: mymoola
JInstaller::install: 不能安装语言文件,因为语言包(用于安装“it-IT”)没有被安装或者不存在。

前后2次都这样, 会不会影响使用?

登录 或者   注册一个会员帐号 来参与讨论